
CDP Installation Notes - PC

~ Installation of the CDP System on PC ~

The Installation

This installation of the complete CDP System for PC computers is supplied in separate zip files, one for 
the Sound Loom GUI, one for the Soundshaper  GUI and one for the CDP Documentation.  Each contains
a self-extracting installation  .exe  file: Both the Sound Loom and Soundshaper  files include the CDP 
software executables, which install into the same folder (to avoid any conflicts). 

All of these are downloaded via the CDP Download site.  Other key sites are listed for your information:

The CDP Download site is: https://www.unstablesounds.net/cdp.html
Robert Fraser’s Download site (Soundshaper)  is:  https://www.soundshaper.net/dloads.html
Trevor Wishart’s Website (SoundLoom) is: http://www.trevorwishart.co.uk
Richard Dobson’s Website is: http://www.rwdobson.com 
The CDP Forum is:  https://www.unstablesounds.net/cdpforum

Prepare

If you already have CDP-InstallationNotesPC.pdf  (this document) and CDP-Check_Installation-PC.pdf 
(so that you can familiarise yourself with where to find everything after installation), please read the 
Installation document first / print it out so that you will have all the installation steps to hand.

If you do not already have the Installation Documents, please DOWNLOAD InstallationDocumentsPC-
MAC.zip.  The installation instructions for both PC and MAC are included in this zip file.

Step 1: install SoundLoom

• Download the zip file SoundLoom1704_PC.zip, e.g., to your downloads folder.  

• Double-click the self-extracting file InstallSoundLoom1704_PC.exe. A dialog box suggests unzipping 
the files to the folder  C:\cdpr7.  This is the recommended base folder for all CDP files.You can change 
this to any other drive of your choice. The installation will create the folder  \cdpr7 if it does not exist 
already.

You are recommended to keep the folder name cdpr7. If you do change it, please make sure there are 
no spaces in the path (not  C:\Program Files\cdpr7, for example). 
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The installation  places the folder _cdp inside cdpr7. The folder _cdp  contains the subfolders and 
executable for SoundLoom (soundloom.exe, which is currently version 1.7.04, and as a backup, the 
previous version soundloom1703.exe).   

The subfolder _cdprogs contains all of the CDP executable programs, currently Version 711 as well as 
the contents of the SoundLoom Data Pack.  

(The reason to unzip to a top level folder is so that that paths will be as short as possible;  otherwise you 
may be unable to see the full filename of a soundfile when located at the end of a long path.)

Step 2: install Soundshaper
This step may be taken before Step 1, if you prefer. 

• Download the zip file SoundshaperFULL.zip,  e.g., to your downloads folder.  
(This link takes you direct to the Soundshaper website so you are sure of getting the latest version.  
Updates can later be downloaded from this site as well.)

• Double-click the self -extracting file InstallSoundshaper6.exe  A dialog box suggests unzipping the files
to the folder  C:\cdpr7.  This is the recommended base folder for all CDP files. You can change this to 
any other drive of your choice. 

If you wish to install Soundshaper and Soundloom in separate locations, you can change the folder \cdpr7
to another name, but please make sure there are no spaces in the path (not  C:\Program Files\cdpr7, 
for example). 

The installation will create the folder  \cdpr7 if it does not exist already. The subfolder _cdprogs contains
all of the CDP executable programs, currently Version 711. 

Within \cdpr7 it also creates the folder \Soundshaper6, containing four subfolders, Soundshaper.exe  
and other files.  Soundshaper’s  \docs subfolder has various  informative files about Soundshaper and 
how it works.  It does not contain the Soundshaper Manual: this is included with the CDP Documentation
(see Step 3).
.

Step 3: install the CDP documentation

• Download the zip file CDPR711documentationPC-MAC.zip ,  e.g. to your downloads folder.  

• Double-click the self -extracting file InstallCDPDocumentation.exe   Unzip this to \cdpr7, as 
recommended for Steps 1 and 2.   The installation  will create the subfolder \docs within  \cdpr7.

 You will now see the index to the Reference documentation, index.html in \docs and some other 
generally useful documents.  The files for the complete CDP Reference Documentation are in \docs\html,
and the various Tutorials for the CDP software are in \docs\htmltuts.  There are a number of CDP demos 
in _docs\demo which form a useful introduction to the software.  You will find a comprehensive listing 
of what these folders contain in CDP-Check-Installation-PC.pdf.

The CDP Guide by Robert Fraser is already installed:  \docs\guide\cdpguide.html.   The new A 
Learning Manual for CDP by Archer Endrich can be downloaded from the CDP Website, as well as
three additional tutorial workshops of a more advanced nature 
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NB:  The \MAC folder also has the file Manualconfig.pdf, which is only needed by MAC users.

The documentation also includes the latest Soundshaper Manual. After unzipping, you will find this in
 \cdpr7\docs\Soundshaper;  the index is MANUAL.html.  The Manual can also be accessed from within
Soundshaper. Updates are posted on the Soundshaper website (see link above).
.

Online Documentation
The CDP documentation is also available online at: 
   http://www.ensemble-software.net/CDPDocs/html/cdphome.htm

This is the latest version: check the documentation Downloads page for updates. The offline 
documentation can also be downloaded from here.  (In future, the documentation will be moved to the 
CDP website, but links will be provided.)  The online documentation can also be accessed from within 
Soundshaper if you  have Options->CDP Online Docs  ticked.

YOUR INSTALLATION IS NOW COMPLETE.  

THE REST OF THIS DOCUMENT PROVIDES INFORMATION TO HELP YOU 
UNDERSTAND THE CDP SYSTEM AND GET STARTED.

Configuring Soundshaper

When you first run Soundshaper, it creates  a default configuration file:  Soundshaper.cfg.  (This should 
work as is, if you have installed to the standard CDP setup with the root directory as C:\CDPR7.)

If you wish to customise the Soundshaper settings for your personal use, you can do this via the Options 
-> Settings buttons in Soundshaper.  A synopsis of the basic information is provided in the section below 
titled ‘About the Path to the Programs’ (pp.4-6).  A complete description of how to do this is available in 
the Soundshaper Manual -> OTHER PAGES -> Settings.

The essential paths that enable Soundshaper to find programs and documentation are:
 F`or the CDP programs:  C:\CDPR7\_cdp\cdprogs (the drive and name of the root directory can 

be different, but need to populate the various fields of the configuration file.)
 For the Help documentation (both CDP Reference and the Soundshaper Manual):  

    C:\cdpr7\docs
(Help is accessed via the Help button on Soundshapers main navigation bar.)
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Overview of the System

After you unpack your downloads, this is an overview of what you should see: 

 \cdpr7 folder created in your home directory, inside which will be:
  
    \_cdp and its subfolders.  This is the main CDP environment, with the CDP executables in \_cdprogs 
and the required SoundLoom files in the other folders.

    \docs containing
        The CDP Welcome 2020, and backup copies of the Installation Notes and Check_Installation 
pdfs.  \docs also contains index.html, the link to the Reference Documentation, SLguide-basic.pdf, an 
introduction to the operation of Soundloom, and twSoundLoomGuide.pdf - Trevor Wishart's 
comprehensive guide to the CDP System as run from his Sound Loom GUI.  There is also some 
information about Release 6 and Release 7 programs.  Manualconfig-MAC.pdf relates to MAC systems.
There is also a copy in \cdpr7\MAC.

See CDP-Check_Installation-PC.pdf for a full run-down on the contents of the various folders.  This 
has been prepared both as a way to check if your installation 'looks right' and as a way to see at a glance 
what the CDP System contains.

There are two new documents that may be of great use to those exploring the CDP software for the first 
time or seeking to gain additional fluency.  These are CDPguide by Robert Fraser and A Learning 
Manual for CDP by Archer Endrich.  The former is included in the CDP Documentation download and 
the latter can be downloaded from the CDP Website (ca 400+ Mb as it has many sound examples).

About the Path to the Programs

Your CDP paths are very likely to be set up properly already.  This section is provided for your 
information so that you can understand what’s going on behind the scenes and know how to 
create customised settings.

Again, you are recommended to install CDP on the top level of C: (or another Drive).  Thus the path to 
the CDP programs will begin C:\cdpr7\...  However, you can place and name the main CDP folder as 
you wish ─ just make sure that the correct path is set as described below. 

PATHS 1.  THE PATH FOR SOUNDLOOM

For the Soundloom GUI the location of the CDP executables is automatically set to 

C:\cdpr7\_cdp\_cdprogs

If you need to change this, for example of your CDP root directory has a different name or location, you 
are best advised to do this from within SoundLoom:  

CDP Installation Notes - PC Page 4



System State (top right corner) -> SYSTEM SETTINGS 2 -> SET DIRECTORY for CDP 
PROGRAMS

If absolutely necessary, you can edit execloc.cdp  ̶  cdpr7\_cdp\_cdpenv\execloc.cdp

PATHS 2.  THE PATH FOR COMMAND LINE USE

You may choose to run the CDP programs from the Command Line Interpreter (‘CLI’).  This is 
especially powerful if using batch files, but is also useful to check the operation of a program 
independently of the GUIs.  The Command Line Interpreter on PC is cmd.exe, which can be found in C:\
Windows\System32.    A desktop shortcut is recommended OR put a copy of cmd.exe in the folder 
where you will be working so that it will be active in that directory.

To get the Command Line interpreter to find the CDP executables from any location, add the path to the 
CDP executables to the PC System Path.  The System Path is accessed via the Control Panel:  System ->
advanced system settings -> environment variables -> system variables (edit to add the CDP path 
according to your CDP setup.

 Pre Windows 10 – the path should be added to the existing path (ensure that there is a semicolon 
after the previous item), start with the Drive name and place a semicolon at the end of the CDP 
path:  for example, C:\cdpr7\_cdp\_cdprogs;

 Windows 10 – the various path items are placed on separate lines, starting with the Drive name, 
but omitting the semicolon at the end.  Right-click the Windows icon (bottom left) and go to 
System -> Advanced system settings -> Environment variables -> System variables.

Setting the wav sound extension in the 'User variables for owner' section of PC environment variables is
no longer needed for CDP Release 7.1 and later.  For your information 'just in case', the variable is 
'CDP_SOUND_EXT' and the value is 'wav'.

Having the CDP path set in the PC system like this gives you complete control.

PATHS 3.  THE PATH FOR SOUNDSHAPER (and some notes about how I (AE) use the system)

The Soundshaper GUI has an environment settings file;  The Default is Soundshaper.cfg .  If you have the
older .evt configuration files, you can just change the .evt to .cfg and it can be used with Version 5.07 and
above.  If you are updating from a previous version, Soundshaper will automatically update your old 
Default .evt file to a .cfg.  You can also create additional customised .cfg files (see below), these files can 
be any name plus (as of Version 5.07) a .cfg extension, but retain the Default Soundshaper.cfg because 
Soundshaper will always read this Default file first to ensure that certain settings are in place.  You can 
then select your own customised .cfg file.

When you first open Soundshaper you will be asked about where your programs are etc ─ all to do with 
setting paths.  When you finish answering these questions, the Default configuration file will be updated 
accordingly.  (You may or may not have changed the paths.)  Then click on the INITIAL SETUP 
Save+Exit button.

Here is a screenshot of the Default Soundshaper.cfg provided with the download as set up when the main 
directory is \cdpr7
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Here is what the various entries mean:

 TEMP. OUTFILES  C:\cdpr7\TEMP - where the soundfiles that you create are placed.  You 
can go to Open a soundfile and it will be there, showing that both infiles and outfiles will be in 
TEMP if your Project Folder is also TEMP.

 CDP PROGRAMS - C:\cdpr7\_cdp\_cdprogs - the all-important path to the CDP executables
 PROJECT FOLDER  C:\cdpr7\TEMP - set initially to the TEMP folder, but can be changed at

any time to any current project folder, for quick loading of soundfiles.
 USER DATA FILES  C:\cdpr7\TXT - Soundshaper-created text files are placed in variously 

named sub-folders of TXT.  These folders are not empty;  they already have files for default 
values.  When you create a supplementary breakpoint or textfile within Soundshaper for a 
particular process, Soundshaper saves it to a sub-folder of \txt with that process name.  For 
example, a TEXTURE note data file will go to \txt\texture and you will be able to find it there.  
In this way Soundshaper assembles all the supplementary files you have created for a particular 
process.

 HELP DOCS  C:\cdpr7\docs – This will enable access to both the CDP Reference 
Documentation and the Soundshaper Manual from within Soundshaper   Go to the Soundshaper 
Help button (top right on the main navigation bar).

 PATCHES  C:\cdpr7\TXT\PATCHES - these are processes as run on the Soundshaper Grid 
and are saved with the name of the source sound and the parameter values used.  They are the 
Soundshaper equivalent of command line batch files.
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The Personal (customised) configuration files option

The configuration file can be accessed in Soundshaper via the Options>Settings menu item;  you will 
notice that at the bottom of the dialogue there is a Save As button for 'Personal.cfg'.  This means that 
you can create your own versions of the configuration file for special purposes.  It is my (Archer) practice
to create a number of Personal configuration files when I'm working on a major project, e.g., one for 
source soundfiles and their initial transformations, one for the transformations of particularly important 
source files, one for mixes, etc.  I set the TEMP OUTFILES, PROJECT FOLDER and USER DATA 
FILES to my current project working directory and name soundfiles and related data files with the same 
root so that I can easily relate them and recall them for future editing.  But that's just one way of handling 
this very adaptable environment.

Hint:  You can make the list of available configuration files come up when you open Soundshaper by 
going to Options > Settings , and then select the OPTIONS tab and tick Alternative Settings.

Below is a screen of a customised configuration file.  This one is for processing the 'tsh' source sound (a 
3' x 6' thunder sheet).  I set Soundshaper to the \j-j\tsh folder to that I could easily load and save 
soundfiles related to the transformations of tsh.wav (a thundersheet source file).  I use lots of different 
configuration files when working on a big project and copy final versions of sounds to a \mix folder for 
mixing.

[SShArcherTshCFG.jpg]

Hint:  Because CDP uses a number of different types of file, each with their own extension, it is very 
useful to have file extensions visible on your PC so that you can tell at a glance what type of file you are 
looking at.  To show file extensions, go to Tools -> Folder Options -> View tab and ensure that 'Hide 
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extensions for known file types' is not ticked.  (There is a list of the various CDP file extensions at the end
of the CDP Desk Reference in C:\cdpr7\docs\DeskReference.)

Breakpoint and text files in Soundshaper
CDP uses many text files, including time-varying breakpoint files (.brk) for automation. By default, 
Soundshaper  looks for these in the User Datafiles folder (e.g. \cdpr7\TXT) and most processes have a 
basic file in  process subfolders, which will load automatically. (You can save your own versions of these,
as you wish.)  Project-specific text files can be kept within these subfolders, although it may often be 
better to keep them elsewhere, e.g. in your current Project Folder. (A shortcut link from the process 
subfolder to the alternative folder can save time.)

I (AE) tend to prepare my supplementary breakpoint and text files with a text editor beforehand and then 
open them in a Soundshaper parameter dialogue. This way they stay inside my chosen folder. A quick 
way of creating  a text or breakpoint file is to write one line, then highlight it and save it to the clipboard, 
duplicate it (Control-V paste) and then edit the duplicates.  This can save a lot of typing.  Thoughtfully 
designed breakpoint and text files greatly enhance results.

Soundshaper Upgrades and Updates
You may want to check at various times whether there are any Upgrades or Updates for the Soundshaper 
GUI.  To do this, please go to https://www.soundshaper.net/dloads.html and follow the instructions 
provided.  

I hope that this document and CDP-Check_Installation-PC.pdf will have made you sufficiently 
comfortable with the CDP setup so that you will easily be able to place the new files in their proper 
locations.  The same is true of Soundloom and any documentation updates that might come through.  You 
are recommended first to rename your existing Soundshaper and/or Soundloom GUI before putting in the 
new one, so that you will have a fall-back.

Some Hints for Getting Started

This section is provided for overall user orientation, to help you get started.

Optional ways to run the CDP software / key manuals

The CDP Software can be run via the Soundshaper GUI, the Soundloom GUI, or the Command Line 
Interpreter (cmd.exe as above).  For the CDP Reference Documentation, create a Shortcut for 
C:\cdpr7\docs\index.html.

The manual for Soundshaper is MANUAL.html, which is located in cdpr7\docs\Soundshaper\.  The 
manual for Soundloom is Sndloom.htm which is located in \cdpr7\docs\html.

For Soundloom you are recommended to start with my SLguide-basic.pdf located in \cdpr7\docs\ ─ this 
explains the basic operation of the three panels and gives worked examples for both the Time and 
Spectral Domains.  Also see twSoundLoomGuide.pdf, which is about using the CDP software from within
Soundloom, a comprehensive document written by Trevor Wishart.

The Soundloom GUI executable is located in \_cdp and the Soundshaper GUI executable is located in \
Soundshaper5, both of which are inside the main folder, \cdpr7.  Both are run by double-clicking on the 
filename:  soundloom.exe (in cdpr7\_cdp) and Soundshaper.exe (in \cdpr7\Soundshaper5).
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CDP-guide by Robert Fraser in \docs\guide provides a great overview of the software.  It groups the 
processes and provides a concise description of each one.  It is a good place to start to get a feel for what 
CDP sound transformations can achieve   ̶  bearing in mind that continuous sculpting of a sound (the 
output of one process becomes an input to the next) produces the most tailored and innovative results.

Desktop Shortcuts

You are recommended to make a Desktop Shortcut for the GUI(s) as well as for the CDP Reference 
Documentation.  The file for the shortcut to the Reference Documentation is \cdpr7\docs\index.html.  
This is the HTML 5 documentation revised by Robert Fraser.  Also note \cdpr7\docs\DeskReference.  
This folder contains the files for the CDP Desk Reference, a landscape document which lists all the 
programs, types of input file needed, their modes and a brief description of each mode.  I find that I use 
this all the time, partly to check details, and partly just to browse it when I'm looking for which program 
might achieve some desired goal.

Robert Fraser’s new CDP Guide (it is in a folder in \cdpr7\docs or downloadable from his Website) 
offers a comprehensive list of all the CDP processes, with concise descriptions.  It can be used via its 
HTML links and there are also pdf versions of the files that can be printed out.  This and the Desk 
Reference are for me absolutely essential aids to finding transformation processes appropriate for a 
composition objective.

Time Domain / Spectral Domain

Soundshaper uses a standard PC menu structure, so you can check it out by clicking on the menu items.  
Note that the Time-Domain programs (amplitude and time sample data) and Spectral-Domain programs 
(amplitude and frequency data) are under separate menu items.  It is important to remember that Time-
Domain programs take a soundfile (.wav) as input, either stereo or mono depending on the program, and 
the Spectral Domain programs take an analysis file (.ana) as input, and this analysis file needs to be made
from a mono soundfile (using PVOC).

Note that Soundshaper has an in-built AUTO-CONVERT function so that the correct file format will be 
used for a given process (i.e., you can provide a .wav Stereo file for a Spectral Domain process that 
requires a .ana Mono input, and Soundshaper will sort it out automatically.  Even so, it is good to know 
which type of file is needed, for example, should you are using Soundloom or the Command Line.

Secondary inputs

When getting used to Soundshaper, check out loading a sound or analysis file and using the Patchgrid.  
Some CDP programs require two input soundfiles.  Soundshaper will prompt you to select a second file, 
as required.  Further details are given in the Soundshaper Manual.  ‘Two inputs’ is a topic covered 
thoroughly in A Learning Manual for CDP.

Sound Loom is designed as an 'intelligent' interface.  Among other things, this means that it 'knows' what 
inputs should be present to run a given process.  If they are not all present in CHOSEN FILES, that 
process remains greyed out.  If this happens when you expect to run a process, double-check the inputs 
required by looking in the Desk Reference or the HTML Reference Documentation ─ to do this you may 
need to figure out the program/process name in these documents that matches the Sound Loom name, as 
they aren't necessarily the same.  Sound Loom names tend to be more descriptive.  There ought to be a list
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of all the process names in Sound Loom and their corresponding CDP Reference File ( = Command line) 
names, but it hasn’t been done yet.

Soundshaper loop points and markers

Soundshaper enables loop points to be set on the graphic display of the soundfile.  Select PLAY FROM 
Loop start  to the left of the soundfile display. Use the left Mouse Button to set Loop Start and the right 
Mouse Button for Loop End.  The loop points can be moved with a click or dragged with the appropriate 
button. 

To the right of the transport buttons are two edit boxes for markers. Markers are arbitrary time-points (up 
to 100), displayed two at a time. If Get  Loops is clicked, the visible markers are set to the loop time 
points. 

You can process a portion of a soundfile bu selecting  PROCESS At Loop Point(s) or At Markers to 
the right.  For example, to crop a soundfile, set the loop points to the desired times, select PROCESS At 
Loop Point(s)  and click the CUT button to extract the looped portion to a separate soundfile.

I myself  (AE) find the Soundshaper 'markers' very useful when I want to fine-tune the marker time points
using my ears.  Select PLAY FROM L to R Marker  to the left of the soundfile display and PROCESS 
At Marker(s) to the right.  You can then enter time points (in seconds only ̶ no minutes!) in the 'Play pt.' 
boxes (Play From and To) to audition parts of a soundfile.  If the purpose of this is to excise that portion, 
when you go to Edit/Mix->EDIT->Cut(extract) the cut points will have been already set by the markers.
This portion is saved as a soundfile which you name, so it is good way to cut up a soundfile into useful 
portions, using both eyes and ears to judge the cut points.

Input soundfile not recognised

One problem that you may encounter is CDP not recognising an input soundfile when it has been made 
by some other software.  This can be caused by non-standard anomalies in the wav header of the 
soundfile made by this other software.  The problem can be rectified by making a CDP copy of this 
program with CDP's COPYSFX (by Richard Dobson).  This can be run from the Command Line 
(copysfx infile.wav  outfile.wav and see Usage for the various options), or via 
Soundshaper (Edit/Mix -> SF UTILS -> Copy/Convert ('COPYSFX')).  COPYSFX is not available in 
a Soundloom menu.  CDP programs retain whatever type the infile is.  Note that the CDP software does 
not handle .mp3, .flac or .ogg files ─ these can be converted with a sound editor such as Audacity.)

Supplementary Observations

You are now ready to go deeper.  You can run the CDP System from the Soundshaper GUI, the 
SoundLoom GUI or via the Command Line Interpreter, as noted above.

Getting started with Sound Loom

For the Soundloom GUI, you are recommended to start with Archer Endrich's SLguide-basic.pdf which 
introduces you to its layout and operation, and has two exercises to work through to get you started, one 
for the Time Domain (sound files) and one for the Spectral Domain (analysis files).  You will find 
SLguide-basic.pdf in the top level of \docs.  You will also find it in \docs-pdf and \docs\SpecialHelp 
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which relates to SoundLoom.  Another tutorial I have prepared for new users is tut12step.htm, which is 
found in \cdpr7\docs\htmltuts\tut12step\.  

Trevor Wishart's  twSoundLoomGuide.pdf is also in the top level of  \docs.  It provides a comprehensive
overview of the CDP System as approached via SoundLoom.

Note that you can Play a sound or analysis file in a Process's parameter dialogue.  When it does this, it is 
playing a temporary file ('cdptest0').  If you are not satisfied with it, you can alter the parameters and run 
again.  The resulting sound or analysis file is not stored on your computer until you Save As.  In 
SoundLoom, when the output is an analysis file I tend to put 'ana' (for 'analysis') in the root name to 
ensure that in future I know it is an analysis file.

Working directory

It would be a good idea to create your own working directory and put one or two mono soundfiles in it, 
e.g., using your initials or a project name as its name.  this was implied in the above in the section about 
Paths.

 If using Soundshaper, working directory has been explained above in the section about Paths.  
Having set this up in the cfg file (Default or Personal), open a soundfile and select a process from 
the Sounds menu.  

 If using SoundLoom, create a directory (folder) on your computer, then in Soundloom use Find 
Any Directory to select your directory (NB:  click on Select, not Open), then Grab a file and Use 
on Workspace as explained in slguide-basic.pdf.

 If using the command line, cd to the directory you want to use.  Enter dirsf (a CDP utility) to get 
a listing of the soundfiles in your directory.  If the list is displayed, your CDP system is working 
properly.  Then try a simple command such as modify speed 2 yoursoundfileIN.wav
processedsoundfileOUT.wav -12  to lower the sound by an octave.  

 Listen to it with pvplay processoundfileOUT.wav.  The wav extension is required with 
pvplay, and hearing the lowered sound will confirm that CDP sound transformation processing is
up and running.  Pvplay -i will play a sound or analysis file immediately, without user 
intervention.

CDP processing programs retain whatever type the infile is, unless it is a program that changes the 
properties or number of channels.  Note that the CDP software does not handle mp3 files ─ these can be 
converted with a sound editor such as Audacity.

Reference Documentation

It is best if Online CDP Help in the Options menu of Soundshaper is ticked.  Also, make a Desktop 
Shortcut to cdpr7\docx\index.html.  The Reference Documentation shows the command line usage for 
the CDP programs and the correct name for the program for command line use.  The two GUIs are often a
bit more descriptive in their names, and there can be some difficulty in connecting the Reference 
Documentation with the menu item.  Soundshaper helps with this by naming the actual program used in 
the bottom right hand corner of the parameters window dialogue.  

Formats of supplementary files

A shortcut is also recommended for the file filestxt.htm (in \cdpr7\docs\html), which illustrates the 
formats for all the different supplementary text files that the CDP programs use  ─ the real power of the 
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system lies in being able to tweak fine detail.  Use 'Index within this file' to see the index of files that are 
illustrated.  The formats for files used by some new programs have yet to be included.  You can also 
access this document from the Main Page of the Reference Documentation:  EXPLAIN -> CHARTS -> 
File Formats (in the Left panel) or CDP FILES AND CODES (in the Main panel).

Multi-Channel Toolkit

If you will be working with multi-channel soundfiles (2+ channels), Richard Dobson has contributed the 
Multi-Channel Toolkit for CDP.  This handles a number of specialised tasks relating to multi-channel 
(including Ambisonic) soundfiles.  These programs are present in the main CDP Distribution and 
referenced in the documentation (cmrefmn.htm in \docs\html and mctoolkit.pdf in \docs-pdf)..  See the 
M-C TOOLKIT link in the left panel of the Main index.  His Website link is:  
http://www.rwdobson.com/mctools.html.  As this is a specialised package, you are invited to donate to 
his running costs.

Demos

Note the three sets of demonstrations in \cdpr7\docs\demo.  They will help you get much deeper into 
sound transformation processing more quickly as they show the operation of the software in considerable 
detail.

Tutorial Workshops (for download)

As you get more familiar with using the CDP System, you may want to delve deeper via three major 
Workshop tutorials.  These can be downloaded from the CDP Website and placed anywhere on your hard 
disk.:  https://www.composersdesktop.com/Tutorials.

  CDPWorkshop1 - 170 + worked examples in 9 program groups with a playlist
  CDPWorkshop2 - in-depth study of the TEXTURE Set
  CDPWorkshop3 - about transposition and shifting, especially the advanced possibilities in COMBINE, 
with additional information about the use of the -p and -f flags when extracting formants.

  NEW:  A Learning Manual for CDP by Archer Endrich:  33+ separate documents about 5 topics, with 
many sound examples.  It draws upon his experience as a CDP user, covering basic operation, processes 
that he has found especially useful, and explanations of some things that can be a bit tricky. 

[Archer Endrich & Robert Fraser  - Nov. 2021, revised 1 Dec. 2022]
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